Results 1 to 4 of 4

Thread: Engine light with full system

  1. #1
    Standard Member Santana79's Avatar
    Join Date
    Mar 2020
    Posts
    15
    Thanked: 0

    Engine light with full system

    Hi, I have a new Gen 4 (my 2nd one).... my 1st 1 had a full arrow system and remap done at the same time. My new 1 has had the system transferred from my 1st but map not yet done as still running in. Has anyone had a full system fitted before a remap and if so did you get the engine warning light? And error message saying Engine!? The dealer said to buy a healtech module but I'm concerned there may be issues?

  2. #2
    Forum Admin soofsayer's Avatar
    Join Date
    Aug 2013
    Location
    York
    Posts
    6,740
    Thanked: 2596

    Re: Engine light with full system

    I had a full system on my gen 4 with no engine light and never got round to doing a remap.

  3. #3
    2 YEAR PREMIER MEMBER Corkgsxr's Avatar
    Join Date
    Jan 2017
    Posts
    672
    Thanked: 223

    Re: Engine light with full system

    Did you disconnect exhaust valves or tie them up

  4. #4
    2 YEAR PREMIER MEMBER ekdg's Avatar
    Join Date
    Mar 2012
    Location
    Chesterfield, Derbyshire
    Riding
    2020 M sport
    Posts
    659
    Thanked: 52

    Re: Engine light with full system

    if you fit a AKRO full system it comes with some parts that fit in the servo motor, this will then trick the system and you do not get the fault codes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •