Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Valve spring failure warning

  1. #11
    1 YEAR PREMIER MEMBER bmwbadboy's Avatar
    Join Date
    May 2018
    Location
    London
    Posts
    2,888
    Thanked: 823

    Re: Valve spring failure warning

    Quote Originally Posted by TheGodfather View Post
    Well new switc gear fitted and bike is still dead as a dodo. Im going to try the fuses later dispite no obvious breaks.
    Very odd that the blue 15amp one is full of white dust/powder like corrosion. Bike has never been left outside or seen rain, other than washing.
    Any new developments ? Did you manage to get rid of error message ?

  2. #12
    2 YEAR PREMIER MEMBER TheGodfather's Avatar
    Join Date
    Jun 2019
    Posts
    656
    Thanked: 122

    Re: Valve spring failure warning

    Quote Originally Posted by bmwbadboy View Post
    Any new developments ? Did you manage to get rid of error message ?
    Its booked in at dealers on Tuesday. I have to leave it with them.

  3. #13
    2 YEAR PREMIER MEMBER TheGodfather's Avatar
    Join Date
    Jun 2019
    Posts
    656
    Thanked: 122

    Re: Valve spring failure warning

    Turns out it was a flat battery after all. Very odd as its kept on a trickle charge and was on track one day then 2 days after my spill is when I got the problem. Battery is fine and no recorded errors dispite what the dash said. Tech thought my smashed in switch gear could have been taking a drawer but don't know for sure.
    I never thought to check battery as it was fine 2 days prior and I've never had an issue. No tracker on my bike either.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •