Results 1 to 9 of 9

Thread: Gen1 Quick Shift Issues?

  1. #1
    1 YEAR PREMIER MEMBER JoePeps's Avatar
    Join Date
    May 2016
    Posts
    235
    Thanked: 78

    Gen1 Quick Shift Issues?

    My quickshifter no longer works after changing back to standard rearsets when riding, but it does work when the bike is on the paddock stand......

    Anyone got any ideas?!

  2. #2
    2 YEAR PREMIER MEMBER baz's Avatar
    Join Date
    Jul 2012
    Location
    attleborough norfolk
    Posts
    668
    Thanked: 148

    Re: Gen1 Quick Shift Issues?

    It's probably you!
    Foot position in relation to the lever,boots etc. can often cause problems(mainly so,on earlier bikes).

  3. #3
    2 YEAR PREMIER MEMBER r25sti's Avatar
    Join Date
    Jul 2012
    Location
    herefordshire
    Posts
    935
    Thanked: 423

    Re: Gen1 Quick Shift Issues?

    have you calibrated it?

  4. #4
    1 YEAR PREMIER MEMBER JoePeps's Avatar
    Join Date
    May 2016
    Posts
    235
    Thanked: 78

    Re: Gen1 Quick Shift Issues?

    Quote Originally Posted by baz View Post
    It's probably you!
    Foot position in relation to the lever,boots etc. can often cause problems(mainly so,on earlier bikes).
    100% not me, I know how to change gear!
    The lever lifts up but just hits a hard stop and no gear change.

  5. #5
    1 YEAR PREMIER MEMBER JoePeps's Avatar
    Join Date
    May 2016
    Posts
    235
    Thanked: 78

    Re: Gen1 Quick Shift Issues?

    Quote Originally Posted by r25sti View Post
    have you calibrated it?
    No, never knew there was an option?

  6. #6
    1 YEAR PREMIER MEMBER JoePeps's Avatar
    Join Date
    May 2016
    Posts
    235
    Thanked: 78

    Re: Gen1 Quick Shift Issues?

    Rode the bike back home today and it definitely isn't working, anyone got any ideas? What is the calibration all about?!

  7. #7
    Forum Moderator alex's Avatar
    Join Date
    Apr 2014
    Location
    London and Norfolk
    Riding
    2017 S1000RR Grey
    Posts
    7,037
    Thanked: 2183

    Re: Gen1 Quick Shift Issues?

    If its well out of synch then you need to visit the dealer to recalib.

    But check chain slack, clutch lever microswitch and then stick it on a paddock stand and clutch change it into each gear for 10+ seconds at a time.

    - Alex

  8. #8
    1 YEAR PREMIER MEMBER JoePeps's Avatar
    Join Date
    May 2016
    Posts
    235
    Thanked: 78

    Re: Gen1 Quick Shift Issues?

    Quote Originally Posted by alex View Post
    If its well out of synch then you need to visit the dealer to recalib.

    But check chain slack, clutch lever microswitch and then stick it on a paddock stand and clutch change it into each gear for 10+ seconds at a time.

    - Alex
    Thanks mate, will do.
    Do you mean 10 seconds in 1st, 10 seconds in 2nd etc? Do I need to use throttle or just idle?

  9. #9
    Forum Moderator alex's Avatar
    Join Date
    Apr 2014
    Location
    London and Norfolk
    Riding
    2017 S1000RR Grey
    Posts
    7,037
    Thanked: 2183

    Re: Gen1 Quick Shift Issues?

    Yes 10 in each. Clutched changes. Idle is fine


    - Alex
    Last edited by alex; 11th January 2019 at 04:53 PM.

  10. The Following User Says Thank You to alex For This Useful Post:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •