Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: 2013 LH switchgear ?

  1. #11
    Standard Member pauly's Avatar
    Join Date
    Oct 2013
    Posts
    139
    Thanked: 0

    Re: 2013 LH switchgear ?

    The ABS light doesn't turn off when I move off after starting when the bike is cold. As I said if I do a few miles and then restart the engine the ABS operates correctly. That and the hazard lights and main beam coming on randomly makes me think it's the switchgear.

  2. #12
    Forum Vendor Stephen's Avatar
    Join Date
    Jan 2016
    Location
    West Yorkshire
    Riding
    2015 S1000RR Black
    Posts
    784
    Thanked: 350

    Re: 2013 LH switchgear ?

    Usually the fault with the switch gears are broken circuits due to corrosion, what your describing sounds like a short. Lots of the wires in the switch gear use the same common signal wire to save on wires. The first thing I would check is that the wires to the switch gear are ok and not worn in any way.

    Failing that I can inspect the switch gear for you and see if their is a fault.

    When the hazards or main beam come on are you able to switch them off immediately?

  3. The Following User Says Thank You to Stephen For This Useful Post:


  4. #13
    Standard Member pauly's Avatar
    Join Date
    Oct 2013
    Posts
    139
    Thanked: 0

    Re: 2013 LH switchgear ?

    Hello Stephen,

    Yes I can turn the hazards and main beam off straight away. I'd never used either before and it took me a minute find out where they were to start with. I wondered if I'd inadvertently knocked them on the first time but it's happened 2 or 3 times now. Is there anything I have to be careful of when opening the switchgear ?

  5. #14
    Standard Member paul_m's Avatar
    Join Date
    Dec 2016
    Location
    Wakefield
    Riding
    2016 BMW S1000RR
    Posts
    502
    Thanked: 113

    Re: 2013 LH switchgear ?

    Get alpha mate.

    Sent from my SM-G920F using Tapatalk
    Cheers, Paul

  6. #15
    Forum Vendor Stephen's Avatar
    Join Date
    Jan 2016
    Location
    West Yorkshire
    Riding
    2015 S1000RR Black
    Posts
    784
    Thanked: 350

    Re: 2013 LH switchgear ?

    Quote Originally Posted by pauly View Post
    Hello Stephen,

    Yes I can turn the hazards and main beam off straight away. I'd never used either before and it took me a minute find out where they were to start with. I wondered if I'd inadvertently knocked them on the first time but it's happened 2 or 3 times now. Is there anything I have to be careful of when opening the switchgear ?
    You should remove the bar end weight, remove the little plastic piece that clips over the wires then you can unplug the heated grips and the switchgear. Then if you push the rubber of the grip away from the switch you should see a torx screw, remove this and the whole unit (grip and switch) will (gently) slide off the bar.

    I would then check the wiring loom for any damage.

    If you remove the two screws from the back of the switch the back case should come off but be gentle as there are plastic tabs at the end to hold it on.

    You can then press the little plastic tab to remove the grip.

    There is then one more screw and the front of the switch will come off. If your confident to strip it down that far post some pics up and I'll have a see if there's anything unusual.

    As I said before it's usually broken circuits in the switchgears whereas what you're describing is a possible short circuit...

  7. #16
    Standard Member pauly's Avatar
    Join Date
    Oct 2013
    Posts
    139
    Thanked: 0

    Re: 2013 LH switchgear ?

    Quote Originally Posted by Stephen View Post


    As I said before it's usually broken circuits in the switchgears whereas what you're describing is a possible short circuit...
    Thanks.

    Are either faults economically repairable ?

  8. #17
    Forum Vendor Stephen's Avatar
    Join Date
    Jan 2016
    Location
    West Yorkshire
    Riding
    2015 S1000RR Black
    Posts
    784
    Thanked: 350

    Re: 2013 LH switchgear ?

    Quote Originally Posted by pauly View Post
    Are either faults economically repairable ?
    yea, I charge £35 if i can fix it(incl return postage). If you post it to me i'll have a look, if i cant fix it id just ask that you pay the return postage... so far ive fixed every one, but ive not had one with your fault before, i'm not certain its the switchgear at fault.

  9. #18
    Standard Member pauly's Avatar
    Join Date
    Oct 2013
    Posts
    139
    Thanked: 0

    Re: 2013 LH switchgear ?

    Had a quick look at the LH switchgear today and noticed it's quite loose on the bar, also the heated grip button is on the RH side on my bike. If I don't get any joy from BMW I'll get you to have a look at the switchgear for me.

  10. #19
    Standard Member pauly's Avatar
    Join Date
    Oct 2013
    Posts
    139
    Thanked: 0

    Re: 2013 LH switchgear ?

    Just to update, BMW have agreed to cover the cost of the switch gear so it's turned out OK. Fair play to them on a 3.5 year old bike, perhaps the dealer service history helped.

  11. #20
    Standard Member Stefleach123's Avatar
    Join Date
    Nov 2018
    Posts
    4
    Thanked: 1

    Re: 2013 LH switchgear ?

    Stephen could you send me
    Your details and il send you my switch gear to
    Have a look at please

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •